Page 1 of 1

request more info on P1BA1 - DTC code

Posted: Sat Jun 20, 2020 2:25 pm
by Neel
hello experts,
today after bit longer drive than normal , 50 KM one way , i have check EV light pop
i restart the car and it gone , it come back after 5 minute , so i stop again
i plug my konnwei and start soulspy to check , no any code show even check ev light ON .
so i decided to check with Torque app to see if it shows something
and torque shows P1BA1 - powertrain
but i feel nothing while driving / no turtle or anything
while google this P1BA1 - is specific for hybrid / electric car is main battery interface control module
link - https://www.autocodes.com/p1ba1.html#:~ ... %20Voltage

car is - 2016 kia soul (Ex- Teo taxi)
millage - 125500KM ( no warranty left)
battery SoH - 94.5% (60% SOC) - 96.6%(100% SOC)
since last 2 month i charge 80% - GOM 109-113 KM
as today to bit long drive i decided to charge 100% - GOM shows 150KM
as this battery SOH with GOM are respectively OK ? or battery interface control module may have issue as per -P1BA1 code pops ??
is there anyway i can reset this BICM (battery interface contron module )
anyone has encounter this issue ? help appriciated , thanks in advance

Re: request more info on P1BA1 - DTC code

Posted: Sat Jun 20, 2020 4:06 pm
by ksoul2084
Neel wrote:hello experts,
today after bit longer drive than normal , 50 KM one way , i have check EV light pop
i restart the car and it gone , it come back after 5 minute , so i stop again
i plug my konnwei and start soulspy to check , no any code show even check ev light ON .
so i decided to check with Torque app to see if it shows something
and torque shows P1BA1 - powertrain
but i feel nothing while driving / no turtle or anything
while google this P1BA1 - is specific for hybrid / electric car is main battery interface control module
link - https://www.autocodes.com/p1ba1.html#:~ ... %20Voltage

car is - 2016 kia soul (Ex- Teo taxi)
millage - 125500KM ( no warranty left)
battery SoH - 94.5% (60% SOC) - 96.6%(100% SOC)
since last 2 month i charge 80% - GOM 109-113 KM
as today to bit long drive i decided to charge 100% - GOM shows 150KM
as this battery SOH with GOM are respectively OK ? or battery interface control module may have issue as per -P1BA1 code pops ??
is there anyway i can reset this BICM (battery interface contron module )
anyone has encounter this issue ? help appriciated , thanks in advance


I don't know anything about the code you are seeing, but if you are in Canada then your EV warranty is good until 160k. So you would still be covered under warranty. :)

Re: request more info on P1BA1 - DTC code

Posted: Sat Jun 20, 2020 5:50 pm
by Neel
thank you for input,
yes , main battery and related componant are coverd till 160000 KM ,
i will definately approch them , today is first time this code pops
its weekend now and in next 2 days i will find kia ev certified dealer around and book an appointment
** BTW , is there any location diagramme where i can pull/push connectors OR Fuse OR relay
to reset this "main battery interface control module " unless everything blend and shield with main battery

Re: request more info on P1BA1 - DTC code

Posted: Sat Jun 20, 2020 6:16 pm
by JejuSoul
-
P1BA1 - DTC code
It's a battery fan error. The little air blower in the back that cools the main battery.
see the DTC page here - Kia Soul EV CAN Messages

Image

You had a water pump error last week. The EWP at the front is a completely different system than the air pump at the back. There is no connection or joint functionality between these two systems. That you have had both fail in such a short space of time is unusual, but must be assumed to be random bad luck.

-

Re: request more info on P1BA1 - DTC code

Posted: Sun Jun 21, 2020 6:57 am
by langemand
Neel wrote:i plug my konnwei and start soulspy to check , no any code show even check ev light ON .


Weird, Soul EV Spy should display error codes! Which version number do you have?

Are you certain no other app was connected to the OBD dongle? And that the car was fully on, when you started the connection in Soul EV Spy?

If you have the paid version, please email me the SoulEvSpy.2020XXXX_XXXX.txt file from the Download dir: soulspy@evranger.com

Re: request more info on P1BA1 - DTC code

Posted: Sun Jun 21, 2020 12:04 pm
by Neel
Neel wrote:
langemand wrote:
Neel wrote:i plug my konnwei and start soulspy to check , no any code show even check ev light ON .


Weird, Soul EV Spy should display error codes! Which version number do you have?

Are you certain no other app was connected to the OBD dongle? And that the car was fully on, when you started the connection in Soul EV Spy?

If you have the paid version, please email me the SoulEvSpy.2020XXXX_XXXX.txt file from the Download dir: soulspy@evranger.com


thank you for brief information, i am very new to learning and using dongle OBD , i am using -free soul spy,
this code pops first time ,
yesterday , i did highway 110KM speed and 50KM one way strarigh with Air Con ON with set (24 deg ) , outside was 32 Degree very hot and humid so battery may have very streess and hot , whatever reason as you said cooling fan might not ON or firmware bug, but i plug konnwei dongle realtime during my trip return , and light was on but no code , after i reach home , i test same dongle with torque and i got this code,
i am not sure , when i did realtime with soulspy (free) , at that time torque was running in background ( but mostlikely not ) but to clear doubt i will monitor for next 2 days to confirm with soul spy to see , and update here,
thank you

Finally problem found and fix P1BA1 - DTC code

Posted: Sun Jun 28, 2020 8:44 am
by Neel
JejuSoul wrote:-
P1BA1 - DTC code
It's a battery fan error. The little air blower in the back that cools the main battery.
see the DTC page here - Kia Soul EV CAN Messages

Image

You had a water pump error last week. The EWP at the front is a completely different system than the air pump at the back. There is no connection or joint functionality between these two systems. That you have had both fail in such a short space of time is unusual, but must be assumed to be random bad luck.

-


** after whole week monitoring i didn't have any " check EV light " on daily city driving (70-85 KM/H speed ) with AirCon on * not highway driving at all
** although i decide to check battery fan in trunk , and i have no idea how but i found fan connector was NOT connected to fan at all
all this happened while car was charging and fan status ON on torque seems looks all ok , but didn't hear any spinning noise, the moment i plug the connector and fan start to spin showing speed 50 ... now i believe the logic to pop P1BA1 code is , i was driving highwy with 105-115 KM/H with 50KM distant , outside temp was 35+ hot and humid ,.battery become HOT and fan wasn't pluggd (as connector was OFF) didn't cool battery ..i guess hopefully should be ok, still will monitor while highway driving again.
thank you experts