Posts: 6
Joined: Fri Apr 27, 2018 3:15 pm

UVO EV Services failing to activate

Wed May 30, 2018 1:36 pm

Has anyone had issues activating the UVO EV Services? Specifically have you seen the message in the linked pictures below?

I bought my used 2015 Soul EV a little over a month ago, and there is a long painful story of all that has happened since then in trying to activate my UVO between the dealership, the customer service, and the technical people, that I will spare you from.

Essentially, initially my modem showed a bunch of zeros and was not receiving signal. Then they replaced the modem (audio head unit) and now it indicates there is signal, but the Kia technical people in California claim they still can't get signal from the car. Also since they replaced the modem, I get a message every time I turn the car on that attempts to activate the UVO and then fails. (see link below)

I feel like I have explored all possibilities and have yet to find a solution or even the problem, but I know there must be one.

Now Kia wants to replace my modem again, which just doesn't seem logical to me and frankly I don't know if they understand the issue.

Has anyone experienced this or have thoughts?

https://drive.google.com/drive/folders/ ... sp=sharing


Posts: 194
Joined: Fri Mar 06, 2015 7:39 pm
Location: Kelso, WA

Re: UVO EV Services failing to activate

Sat Jun 02, 2018 2:36 pm

That is frustrating. :( The only things that come to my mind are, is the antenna hooked up with a good connection, did they activate the new IMEI number with Verizon or who ever the carrier is, is the replacement modem defective? Does the main display show that it is getting a cellular connection?

Hope it gets figured out soon.
David D. Nelson

Blue 2016 Soul EV+ & Cloud 2018 Soul EV+ :D :o

Posts: 1
Joined: Sat May 19, 2018 11:57 pm

Re: UVO EV Services failing to activate

Sat Jun 02, 2018 9:17 pm

I also bought my used 2015 Soul EV +. I have anothe problem with activation also. My 2015 Soul EV has only Wifi and Bluetooth modems.The car's modem is tied to the VIN of your car. Therefore, if the modem is replaced thay need to replace the MAC address of the modem for the VIN of your car at web server KIA. Otherwise, the service will not see your car when connecting to the Kia server.
Vladimir I. Karnaukh

Posts: 6
Joined: Fri Apr 27, 2018 3:15 pm

Re: UVO EV Services failing to activate

Wed Jun 13, 2018 4:35 pm

Thanks for your suggestions. We checked with Kia and the dealer about all of those things and they claim those aren't the issue here. Communication with them has been difficult, so I can only hope they are understanding what we are suggesting.

As I predicted, even though they were set on replacing the head unit again, nothing changed. Now they are sending a technical person from Kia corporate to the dealer to have a go at it. Fortunately they finally were able to give me a loaner car!

So, many more weeks go by with no progress, but I will keep updating as new info becomes available.



Posts: 1
Joined: Sun Sep 10, 2017 6:07 pm

Re: UVO EV Services failing to activate

Fri Jul 06, 2018 4:59 pm

My car had been in the shop for a week for this. Interestingly enough, this small thing is what they said has been causing my battery in the engine compartment to completely die (3 times). They had to purchase a new unit and promise me this is fixed!

So if for some reason your battery dies....it could be this

Posts: 6
Joined: Fri Apr 27, 2018 3:15 pm

Re: UVO EV Services failing to activate

Wed Jul 25, 2018 7:38 am

SUCCESS! My UVO EV Services are fully functioning now; meaning the car's network functions and I have access to my UVO account to control it via the app.

The technical person from California came to visit the car and did something, maybe?? The guy at the dealership who I had been working with when I finally picked it up refused to tell me what the specific problem was or how he fixed it, but he did claim he had fixed it. I'm just very glad it is over with.

Thanks for your suggestions!


Posts: 73
Joined: Mon Jan 19, 2015 2:56 pm
Location: Long Beach, CA

Re: UVO EV Services failing to activate

Fri Jul 27, 2018 12:02 pm

I bought my 2015 Soul+ new in Feb-'15 and the UVO eco App worked since day-1. Good News: still working. I have App ver. 2.1.8.
Hope this helps.
'15 Soul EV+, '10 Prius

Posts: 2
Joined: Wed Mar 13, 2019 7:38 am

Re: UVO EV Services failing to activate

Wed Mar 13, 2019 9:29 am

In my KIA Soul there is no CarPlay and AndroidAuto. My version of the firmware is ST.PSEV.USA.E447.140904. From which firmware version did CarPlay and AndroidAuto go?
  The official Kia has closed the free update. Where can I download the new firmware for SD card? Can someone throw off the update file? Desirable version E506.160211.
Also I can not activate the UVO from the car! Communication antenna is, but the activation does not work. Network Error!
Now I can update the firmware of my device only through the SD card.

Posts: 2
Joined: Tue Feb 26, 2019 12:07 am

Re: UVO EV Services failing to activate

Fri Mar 22, 2019 7:39 am

Now software updates are available with navigation map update or at dealer.

Return to “Technical Discussions”