mgilpatric
Posts: 4
Joined: Fri Nov 01, 2019 9:45 am

Clipper Creek LCS-20 will not work

Tue Nov 19, 2019 11:56 am

I have a 2016 Soul which charges fine on the standard level 1 charger. To get a faster charge I bought a used Clipper Creek 3.6kw charger. It appears to start working and I get no errors. After 2 minutes the charging system shuts down, the three lights flash on the dash board.

I checked the cable and it appears good and the relay in the charger closes. It seems like the car will not initiate charging. CC says there is no software update that would address this. Could the car need a firmware update? Any other suggestions? I may return the unit to CC to have them diagnose.

Thanks

Calaveras
Posts: 20
Joined: Mon Jun 24, 2019 3:08 pm

Re: Clipper Creek LCS-20 will not work

Tue Nov 19, 2019 5:26 pm

Failures in the EVSE is rare. do you know someone else with an EV that could try it out?
2016 Leaf S bought used in 2017 24 kWh no QC
2017 Soul EV + bought in 2019 for spouse.
Daily commute is 55 miles round trip with a 1,900 foot elevation climb on the way home. Gold Country California

BEC
Posts: 29
Joined: Fri Sep 16, 2016 1:47 pm
Location: Auburn, WA

Re: Clipper Creek LCS-20 will not work

Sat Jan 11, 2020 8:03 pm

I have had a Clipper Creek EVSE fail and they were very gracious about it. The error indication appeared on the EVSE itself.

But this sounds like an OBC (on-board charger) failure. Can you charge the car with the Level 1 EVSE that came with the car? If you can, then get back to Clipper Creek. If you can’t, then this is a Kia issue.
Bernard Cawley
Auburn WA

2016 Caribbean Blue/Clear White EV

Return to “Batteries and Charging”