rjripley
Posts: 2
Joined: Fri Apr 22, 2016 3:54 pm

Electric Water Pump

Fri Apr 22, 2016 4:22 pm

I've had my EV service light come on twice while driving and I'm wondering if anyone else has had the same issue. My Soul EV is under 2 months old.

Both times the light has come on at the end of a roughly one hour, 20 mile commute. If I shut the car off and then turn it back on again, the light is gone.

The first time the light came on I got it checked out and the history code was "p0c73" re: the electric water pump. The dealership performed a pump circulation, confirmed the pump was working, cleared the code, and everything seemed fine. It's been about two weeks and the light has come back on today. Not yet back to the dealer but I suspect the same issue.

Has anyone else had this issue and, if so, does the permanent fix eventually require some kind of repair or replacement? Two trips to the dealer in two weeks for a two month old car is not particularly pleasant.

GizmoEV
Posts: 172
Joined: Fri Mar 06, 2015 7:39 pm
Location: Kelso, WA

Re: Electric Water Pump

Fri Apr 29, 2016 2:52 pm

I was getting intermittent errors on our new Kia Soul EV+ only they were for the battery pack fan. The dealer cleared the codes because everything seemed to work out just fine. When I quit being able to quick charge at AeroVironment charge stations and then got another battery pack fan error code the dealer tech started looking a little deeper and discovered that the resistance of the ground wire was higher than normal. It turned out that the ground wire attached to the front fender well under the hood was not tight. Maybe there is a poor electrical connection somewhere in the wiring that intermittently causes an issue. It might be worth a resistance test of each wire to the pump.
David D. Nelson

Blue 2016 Soul EV+ & Cloud 2018 Soul EV+ :D :o

JejuSoul
Posts: 1128
Joined: Wed Jul 08, 2015 6:47 am
Location: Jeju
Contact: Website

Re: Electric Water Pump

Sat Apr 30, 2016 8:57 pm

Hi rjripley, welcome to the forum.
It's a small group here so replies take a while sometimes.
Hope you enjoy this car despite this glitch.
I have had my car for a year and so far had no problems. I really like this car.
I agree with GizmoEV that the fault may be something trivial like a loose wire or fuse.
I google searched EWP failures and came up with nothing for any EV.
So you are the first. Please report back if you know anything more.
This thread is where people will come if they search for EWP faults.

Anyway I will post the info I do have about the EWP. (more to be added later)
The EWP in the Soul EV is made by Myunghwa Ind.CO.,LTD in South Korea.
see http://www.myunghwa.com/eng/sub02.php?mid=40
On that page is a comparison to the functioning of a belt driven pump (left) with an EWP (right)

Image


The pump sits underneath the coolant reservoir. Here's a photo of it.
(Strangely this website is rotating the image 180 degrees. Click view image and you see it correctly))

Image

Here's a picture with the OBC and the High Voltage Junction Box moved so you can see the Reservoir (the white plastic water tank) and pump beneath.

Image

Here's a schematic of where the EWP moves coolant around.

Image
The codes for using Torque Pro can be found by clicking the link in the website icon under my user name on the left.

rjripley
Posts: 2
Joined: Fri Apr 22, 2016 3:54 pm

Re: Electric Water Pump

Tue Jun 14, 2016 11:23 pm

Thanks for the replies. Dealer said water pump was making strange noises after only a few weeks of use and they replaced it under warranty. Been several weeks now and have had no further issues.

DeeVolt
Posts: 2
Joined: Wed Aug 17, 2016 12:48 pm

Re: Electric Water Pump

Wed Aug 17, 2016 1:09 pm

Hi. We've had our 2016 Soul (3500 miles) ten days now. Today a warning light came on (triangle with a ! And 'EV' at bottom), then one of the turtles (there's two, don't know which one). Drove a mile home and turned off the car. After looking in the manual, it seems to be that the battery pack is hot? Car opperates normally but it is 100 outside. I drove it less than 5 miles in town, 82% charge. Turned car back on and neither of the lights came back on, even after a two mile test drive.
Kia said to "just keep an eye on it"? Will have to have it towed over 3.5 hours away to a certified Kia mechanic.
Has anyone else dealt with this and how critical is it?

SoulEV2016
Posts: 572
Joined: Mon Jul 18, 2016 6:26 am

Re: Electric Water Pump

Wed Aug 17, 2016 1:37 pm

:? the right answer for this "volatile" problem is to buy torque pro and an OBD2 reader.

logs (from torque pro) can be usefull to detect a problem because we have many CSV tracklog to compare a situation when light go ON but with no description.

Example in free service : http://www.4shared.com/folder/-LI8xCXK/Soul-EV.html

;)

Fan for front radiator :
Image

Temperature of the motor with hard driving (mountain) :
Image

Cooling pump and 3way-solenoid checking :
Image
Kia Soul EV 2016 Ultimate 27 kWh - Mountain hard driving (fast). Drain 1/3 of Battery after 32km. - Unlimited highway speed (153km/h at regulator).

GizmoEV
Posts: 172
Joined: Fri Mar 06, 2015 7:39 pm
Location: Kelso, WA

Re: Electric Water Pump

Mon Aug 29, 2016 4:01 pm

DeeVolt wrote:Hi. We've had our 2016 Soul (3500 miles) ten days now. Today a warning light came on (triangle with a ! And 'EV' at bottom), then one of the turtles (there's two, don't know which one). Drove a mile home and turned off the car. After looking in the manual, it seems to be that the battery pack is hot?


Under the hood on either side over the wheel well and shock towers are several bolts with wires under them. Check those to make sure all of them are snug. On our 2016 Soul EV+ we had the same issue and then AeroVironment charge stations would give an error after a few seconds of charging. It turned out to be a loose ground wire on the left fender which went to the battery pack fan.
David D. Nelson

Blue 2016 Soul EV+ & Cloud 2018 Soul EV+ :D :o

DeeVolt
Posts: 2
Joined: Wed Aug 17, 2016 12:48 pm

Re: Electric Water Pump

Tue Aug 30, 2016 12:52 pm

David-thank you for the reply. We've had no further problems but I will check the tightness of the bolts!

JejuSoul
Posts: 1128
Joined: Wed Jul 08, 2015 6:47 am
Location: Jeju
Contact: Website

Re: Electric Water Pump

Sat May 12, 2018 8:00 am

-
I had a look at some Torque logs of a recent driving session in a 2018 Soul EV to watch how the EWP worked as the Temp increased.

I watched the Motor Temperature go up to 55C while driving at 90km/h. This was the lead indicator.
The VMCU MCU Temperature followed this but every time this reached 40C the EWP came on and began cooling it.

When the EWP came on the OBC Water Temp began to rise. Obviously because it is on the same coolant loop.
Next to rise is the OBC Heatsink Temp closely followed by the OBC Inside Temp.
The coolant never went above 37C, The Heat Sink got to 35C and the OBC Inside got to 34C.

I have named two new PIDs for the EWP. 'EWP Control Target' and 'EWP Speed'.
The EWP Control Target was zero at first but changed to 51 every time a few seconds before the EWP came on.
The EWP Speed was zero when it was off and 43, 44 , 49 or 51 when it was on.
The codes for using Torque Pro can be found by clicking the link in the website icon under my user name on the left.

Return to “Technical Discussions”