SDKIA
Posts: 1
Joined: Sat Aug 17, 2019 9:21 pm

Re: Clock does not display when I start the car, it will takes 2 mins to display the clock after I start driving.

Sat Aug 17, 2019 9:29 pm

2015 Soul in the USA. Clock disappeared from display yesterday. Unable to get it to reappear. I found that the clock appears on screen if you press and hold the radio on/off button while starting the car, it disappears when button is released. It shows 12:00 when I am holding the button.
Where does the clock get the time from?

JejuSoul
Posts: 1396
Joined: Wed Jul 08, 2015 6:47 am
Location: Jeju
Contact: Website

Re: Clock does not display when I start the car, it will takes 2 mins to display the clock after I start driving.

Sat Aug 17, 2019 11:38 pm

-
This problem seems to be worldwide, with the exception of Korea.

See also Plus d'heure affichée (GPS?) and Uhr Uhrzeitanzeige tot!?
The codes for using Torque Pro can be found by clicking the link in the website icon under my user name on the left.

ToyToyToy
Posts: 4
Joined: Sun Nov 19, 2017 7:18 am
Location: Germany

Re: Clock does not display when I start the car, it will takes 2 mins to display the clock after I start driving.

Sun Aug 18, 2019 2:17 am

Not only worldwide, but Kia-wide as well. All kind of Kia models are affected: https://www.cargurus.com/Cars/Discussio ... _ds1053034

ToyToyToy
Posts: 4
Joined: Sun Nov 19, 2017 7:18 am
Location: Germany

Re: Clock does not display when I start the car, it will takes 2 mins to display the clock after I start driving.

Sun Aug 18, 2019 5:30 am

There are reports in Germany that the issue is disappearing, clocks are working again.

ksoul2084
Posts: 55
Joined: Thu May 16, 2019 10:48 am

Re: Clock does not display when I start the car, it will takes 2 mins to display the clock after I start driving.

Sun Aug 18, 2019 5:59 am

Some kind of GPS system glitch yesterday? Luckily my Carplay iPhone still knows what time it is... ;)

notfred
Posts: 392
Joined: Thu May 07, 2015 2:28 pm

Re: Clock does not display when I start the car, it will takes 2 mins to display the clock after I start driving.

Mon Aug 19, 2019 1:07 pm

I fixed my clock on my 2016 today. Here's what I did.

1) I turned the car on ready to drive but left it in Park. I waited for the infotainment unit to boot up fully - it should be showing the navigation position and everything running.
2) I used a ballpoint pen to press the reset button. This is a small button inset just above the Map/Voice button on the top right of the infotainment unit.
3) As soon as I pressed the button the screen went dark and the radio stopped playing. I held the button for about 5 more seconds to make sure it was a full reset and then released it.
4) I just drove the car normally. The infotainment unit booted up and the clock still showed "--:--" for a while, even after the navigation started showing my position. At this point I thought it hadn't worked but about a minute or 2 later the clock suddenly started working. Checking in the setup menu for the clock and the options are not greyed out, so it is now working fully!

ksoul2084
Posts: 55
Joined: Thu May 16, 2019 10:48 am

Re: Clock does not display when I start the car, it will takes 2 mins to display the clock after I start driving.

Mon Aug 19, 2019 1:09 pm

Mine self-corrected, I just started it normally and the time was there again.

Strange.

JejuSoul
Posts: 1396
Joined: Wed Jul 08, 2015 6:47 am
Location: Jeju
Contact: Website

Re: Clock does not display when I start the car, it will takes 2 mins to display the clock after I start driving.

Mon Aug 19, 2019 4:28 pm

-
Not just Kia but Hyundai too - My Clock Display went blank and I fixed it by myself

The fix is pushing the reset button.
The codes for using Torque Pro can be found by clicking the link in the website icon under my user name on the left.

Return to “General / Main Kia Soul EV Owners Forum”