NorSoul
Posts: 14
Joined: Wed Dec 30, 2020 11:48 pm

Re: Heat pump stopped working after climate software update SA427

Wed Mar 10, 2021 10:22 am

2016Electric wrote:
Gordo wrote:There's an update out there, at least in Norway. If anybody stateside has any info, please share.


Interesting.. So the heat pump starts working again with the Norway update for 2016 models?

I just got off the phone with the dealer who last checked my car (they have my vin etc). They said there is no new software available for my vehicle at this time.

This is for (Ontario, Canada).

I'll place another likely-to-be frustrating call with kia Canada and see what they have to say. Thanks for the uodate from Norway.


Yes this update fixes the heat pump according to Kia. The update was released in Norway today, so I will hopefully get a call from my dealer tomorrow.

2016Electric
Posts: 179
Joined: Thu Sep 17, 2015 4:05 am
Location: Toronto, Ontario

Re: Heat pump stopped working after climate software update SA427

Wed Mar 10, 2021 11:19 am

notfred wrote:Mine was updated a couple of weeks ago to the bad version. I opened a case on the Kia Canada website yesterday and I'm waiting for the initial reply from them - website says it could be up to 48 hours.


Oh notfred... Whyyyyy? Lol
Out of curiosity, what did your dealer say about this?

I've placed my call to kia Canada and am waiting on a response (asked about the apparent norway fix).

notfred
Posts: 520
Joined: Thu May 07, 2015 2:28 pm

Re: Heat pump stopped working after climate software update SA427

Wed Mar 10, 2021 12:38 pm

My OBC died so I had to take it in. They replaced that, plus did the FATC and EPB updates.

I complained about the AC and they found the thermal expansion valve was leaking so replaced that and recharged it. My parking brake switch was also playing up (broken internally) so they replaced that. The mechanic also found a number of clunks in the front suspension and they replaced: both front stabilizer links, right front lower ball joint, and the rack to pinion steering gear assembly, and then did an alignment. I was surprised by the amount of front end work - I'm driving normal city streets in Ottawa and am generally successful at avoiding potholes in the spring thaw.

OBC was covered under EV warranty, updates were service campaigns so free. Thankfully I'd purchased a fully inclusive warranty when I bought the car because the rest added up to about $2000 and I only had to pay a $100 deductible. I don't normally buy a warranty with a car but with this being a 1st gen model and new technology, and lots of bits that aren't fixable internally but replace for $1-2k I did this time.

I spoke to the service adviser about the FATC update stopping the heat pump from working at lower temperatures and he was unaware. He said they don't actually get told what the logic changes are. From everything I've seen, the mechanics just plug in the GDS/KDS and then talk to KTAC so that's why I've opened the case with them.

Great to hear that there's good news from Norway on this, hope the version gets approved here in Canada soon!

notfred
Posts: 520
Joined: Thu May 07, 2015 2:28 pm

Re: Heat pump stopped working after climate software update SA427

Tue Mar 16, 2021 11:27 am

NorSoul wrote:Yes this update fixes the heat pump according to Kia. The update was released in Norway today, so I will hopefully get a call from my dealer tomorrow.

Any news? Do you have the update on your car? Any pointers to version numbers that we can quote to Kia Canada?

2016Electric
Posts: 179
Joined: Thu Sep 17, 2015 4:05 am
Location: Toronto, Ontario

Re: Heat pump stopped working after climate software update SA427

Tue Mar 16, 2021 12:18 pm

notfred wrote:
NorSoul wrote:Yes this update fixes the heat pump according to Kia. The update was released in Norway today, so I will hopefully get a call from my dealer tomorrow.

Any news? Do you have the update on your car? Any pointers to version numbers that we can quote to Kia Canada?


I can confirm that kia Canada was totally unhelpful, as anticipated. Their response to me was that software from other regions cannot be installed here... Even though that wasn't what I asked (I asked if the same fix would be made available here, to cars sold in Canada). I asked them to clarify their response and am still awaiting a reply.

In all of my unfortunate interactions with kia Canada, I get the distinct sense they at best have zero interest in selling and supporting EVs.. At worst, it comes across as actual contempt/hostility toward the vehicles and their owners.

This will certainly be the last kia product that I ever buy (and by extension Hyundai), given this horrible level of quality control, and zero attempt to correct their error (or even an acknowledgement that they did anything wrong). Never again.

NorSoul
Posts: 14
Joined: Wed Dec 30, 2020 11:48 pm

Re: Heat pump stopped working after climate software update SA427

Wed Mar 17, 2021 10:21 am

notfred wrote:
NorSoul wrote:Yes this update fixes the heat pump according to Kia. The update was released in Norway today, so I will hopefully get a call from my dealer tomorrow.

Any news? Do you have the update on your car? Any pointers to version numbers that we can quote to Kia Canada?


I got the update yesterday, and the heat pump is purring like a tractor again. The SW number is ST.PSEV.EUR.E532.191120, so Europe specific.

notfred
Posts: 520
Joined: Thu May 07, 2015 2:28 pm

Re: Heat pump stopped working after climate software update SA427

Wed Mar 17, 2021 3:09 pm

Thank you for that. Mine is going on to the dealer on Monday so that they can see the behavior. Unfortunately it is warming up here so I'm not sure how many more days we will have for then to get to the bottom of this before October.

Agree on the software version being European only, but at least it's something to start asking questions about what changed in that version and what's the equivalent version for Canada.

YpinEV
Posts: 5
Joined: Tue Feb 02, 2021 1:44 pm
Location: St-Jean, Quebec

Re: Heat pump stopped working after climate software update SA427

Thu Mar 18, 2021 4:22 am

notfred wrote:Thank you for that. Mine is going on to the dealer on Monday so that they can see the behavior. Unfortunately it is warming up here so I'm not sure how many more days we will have for then to get to the bottom of this before October.

Agree on the software version being European only, but at least it's something to start asking questions about what changed in that version and what's the equivalent version for Canada.


Hi notfred,
My dealer (Mega Kia, Brossard, Quebec) are now aware of our problem. They had my car for evaluation and confirmed problem with heatpump. They asked Kia Canada for having issue resolved, but they answerd back there is no problem (!!!!). Looks like they want to avoid extra efforts in fixing issue (hopefully they have enough qualified technical personal to handle correctly). My dealer was VERY reactve, so hopefully when more dealers raise issue, hopefully Kia Canada will listen.

I am waiting for written investigation from my dealer. I will share soon after.

JejuSoul
Posts: 1629
Joined: Wed Jul 08, 2015 6:47 am
Location: Jeju
Contact: Website

Re: Heat pump stopped working after climate software update SA427

Thu Mar 18, 2021 6:20 am

NorSoul wrote:...I got the update yesterday, and the heat pump is purring like a tractor again. The SW number is ST.PSEV.EUR.E532.191120, so Europe specific.

That code is for the map software on your navigation screen. It is not the ROM ID of the FATC update.
It is possible that Europe has different software for the climate computer but I highly doubt it.
Globally all 16MY got update 11 and all 17MY got update 13.

The numbers look like this ( 07 to 12 ) - to get it for your car you will have to be standing next to the Kia mechanic as he performs the update.
( presumably the new update would be 13 or 14 )

Image
The codes for using Torque Pro can be found by clicking the link in the website icon under my user name on the left.

2016Electric
Posts: 179
Joined: Thu Sep 17, 2015 4:05 am
Location: Toronto, Ontario

Re: Heat pump stopped working after climate software update SA427

Thu Mar 18, 2021 12:59 pm

YpinEV wrote:
notfred wrote:Thank you for that. Mine is going on to the dealer on Monday so that they can see the behavior. Unfortunately it is warming up here so I'm not sure how many more days we will have for then to get to the bottom of this before October.

Agree on the software version being European only, but at least it's something to start asking questions about what changed in that version and what's the equivalent version for Canada.


Hi notfred,
My dealer (Mega Kia, Brossard, Quebec) are now aware of our problem. They had my car for evaluation and confirmed problem with heatpump. They asked Kia Canada for having issue resolved, but they answerd back there is no problem (!!!!). Looks like they want to avoid extra efforts in fixing issue (hopefully they have enough qualified technical personal to handle correctly). My dealer was VERY reactve, so hopefully when more dealers raise issue, hopefully Kia Canada will listen.

I am waiting for written investigation from my dealer. I will share soon after.


Thanks for the update. Still no response from kia Canada for me.
What concerns me is that we now have at least three known cases in Canada between you, notfred, and myself.. And that means kia Canada is aware of multiple complaints for the same issue, but are sticking to their script that nothing is wrong.

As you can see from my notes in here, I raised this issue quite.. Shall we say.. Vigorously with the dealer and kia Canada in the fall of 2020.. Yet, several months later, they are feeding you the same lie that nothing is wrong.

Return to “Technical Discussions”