JejuSoul
Posts: 1687
Joined: Wed Jul 08, 2015 6:47 am
Location: Jeju
Contact: Website

Re: Charging Fault error.

-

This thread is old - but still contains lots of useful information.
Posts here no longer show up in Google searches unless you are really specific.
Hopefully by adding this comment the entire thread will get a bit more priority in Google's algorithm.

There are still plenty of OBC errors occurring and the warranty coverage is expiring so DIY information is more important than ever.

Some recent posts :-

2016 needs Onboard Charger
I had to replace mine this winter. I was outside of the 160,000km EV powertrain warranty coverage and paid ~$4,000.
Likely problems with the Kia Soul OBC?
I just bought a Kia Soul on-board charger for $950. I also downloaded the shop manual, which gives the pinouts and other details for this OBC.
Replacing the On board Charger (OBC)
So, in summary:
- The electric water pump stopped working which resulted in the OBC to overheat and fail. That in turn resulted in the 40A fuse to blow.
-
The codes for using Torque Pro can be found by clicking the link in the website icon under my user name on the left.
evsoulnow
Posts: 5
Joined: Sun Jan 05, 2020 7:29 am

Re: Charging Fault error.

US customer. 2016 Soul EV+, 28836 miles. OBC failed with the external charger error. Kia replacing it under the 10 year warranty.
Just posting as another data point. I am out of the country, so cannot check on the details but as it was registered in Feb 2016, I am sure it is the same generation of OBC which has failed in this thread.

OOI have Kia been replacing the water cooler in many/any? I ask as this failure immediately follows record cold here in CO, where it would have been subjected to the worst ambient cold, and windchill - so I am wondering whether the coolant froze (-30C/-22F ambient before w/c). As it would have been standing in that temp overnight, wondering whether this is the root-cause (not identified yet by Kia if it was).
edzee3
Posts: 102
Joined: Mon Jan 19, 2015 2:56 pm
Location: Long Beach, CA

Re: Charging Fault error.

I have a 2015 Soul-EV (US) , new in Feb. '15 (now 24K miles) and all OK until now. Have always used the Reserved (Scheduled) Charging function (set for 12:30 AM start) with my L2 EVSE in my garage. Now, when I plug in the cable, the OBC does the normal click, the middle light on the dash lights up for 3-min., then goes out , and all seems normal.
But, the battery never gets the charge.

The battery does get charged with Immediate Charging set ON (Reserved Charging OFF).

Any suggestions/ideas welcome.

Ed Z
Ed
'15 Soul EV+, '10 Prius
BEC
Posts: 45
Joined: Fri Sep 16, 2016 1:47 pm
Location: Auburn, WA

Re: Charging Fault error.

Well, until you said it charges if you bypass the timer (reserved charging) it sounded like the same onboard battery charger failure others, including myself, have had. For us it would kick off after a short time, regardless of what level 1 or level 2 EVSE was used, and regardless of it happening under a scheduled charge or not. The only way to charge was to use a level 3 charger, which bypasses the OBC.

In your case....some kind of software glitch in the reserve charging function? Or maybe the OBC is just about to quit altogether but somehow hasn't yet?

You are well within warranty limits but if there is an EV-capable Kia dealer in your area, a visit (I know, scheduling can be a pain) is in order.
Bernard Cawley
Auburn WA

2016 Caribbean Blue/Clear White EV
edzee3
Posts: 102
Joined: Mon Jan 19, 2015 2:56 pm
Location: Long Beach, CA

Re: Charging Fault error.

Thanks for the useful reply. I'll be on the lookout for a OBC failure. I do have a service appt. soon for a key-fob-aware problem with Kia-Cerritos (Calif) who should be savvy on these EVs.
Ed
'15 Soul EV+, '10 Prius
JejuSoul
Posts: 1687
Joined: Wed Jul 08, 2015 6:47 am
Location: Jeju
Contact: Website

Re: Charging Fault error.

evsoulnow wrote: Tue Jan 10, 2023 5:31 am ... I ask as this failure immediately follows record cold here in CO, ... wondering whether this is the root-cause (not identified yet by Kia if it was).
The bulk of failures at the start of this thread were in Quebec which led us to suspect that extreme cold was indeed the root-cause. But over the next year or two almost all OBCs failed both in cold and warmer climates. Since then this thread has been very quiet but occasional OBC errors do still occur. No single explanation has been found by us, and nothing at all has been explained by KIA.
edzee3 wrote: Thu Jan 12, 2023 12:24 pm ... Now, when I plug in the cable, the OBC does the normal click, the middle light on the dash lights up for 3-min., then goes out , and all seems normal. But, the battery never gets the charge. The battery does get charged with Immediate Charging set ON (Reserved Charging OFF).
...
The Reserved Charging is set by the Navi Computer. I suspect the software glitch is here and not in the OBC hardware.
Firstly check all the settings on the Reserved Charging page to make sure all is as it should be. Make sure that the time and day is correct by clicking through to the second screen. Sometimes a software update will lose your previous settings.
Secondly if that doesn't help, try updating the Navi Computer software yourself. I had a similar software glitch that I fixed this way.

see Upgrading the Korean Map
The codes for using Torque Pro can be found by clicking the link in the website icon under my user name on the left.
harrimansat
Posts: 1
Joined: Mon Jan 16, 2023 2:52 am

Re: Charging Fault error.

dmfan wrote: Mon May 06, 2019 12:46 am I repaired my OBC.
The problem in capacitors 1mkf
http://images.vfl.ru/ii/1557133189/5889 ... 434825.jpg
Image
Image
Image
Image
Image
Image
Image
Image

Replaced by this

Image

Changed both

Now charge ;)
Hi¡ I have two chargers with the same problen, but the inductor seems to be toast too. Did the capacitor change work?

Return to “Batteries and Charging”