Level 1 charges; level 2 does not - 2016 KIa Soul EV

Kia Soul EV Forum

Help Support Kia Soul EV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Jan 2, 2018
Hi all,

I have a 2016 Kia Soul EV; has about 22,000 miles on it. I have a Level 2 Clipper Creek charger that is now about 2 years old. About 2 months ago, my car would start charging (lights would come on both on car and on charger), then stop. I took it to the dealership that sold it to me and after about a week of discussion with "Kia in California", they narrowed it down to the unit charger or the interior charging cable, finally determining it was the unit charger and replaced that. The car worked fine for 4-5 weeks and now has started doing the same thing again.

The charger has been working fine, charging my sisters Ford C-max Energi hybrid without an issue. I did have the electrician who installed it, though, come out and check it yesterday. It's all working fine, but my sister's car is drawing 13 amps, while mine is drawing less than 1 amp. The really weird thing, though, is that my car will charge using the trickle charger (level 1). (of course, it just takes a long time). The service rep at the dealer said it sounds like there is something wrong with our charging unit, but I don't see how that can be.

Has anyone had this problem or does anyone have any idea what might be going on? I'm taking my car to the dealership on Friday morning and would love to have any feedback here.

Many thanks everyone!

Similar issue for me - my 2016 is failing to charge when my EVSE (OpenEVSE) is set for 28A or more - if I throttle it to 16A, it charges just fine.

I tried someone else’s Chargepoint home L2 at 32A and it failed as well. But lower powered L2 at the office works OK.

The symptom on my L2 at home is that when I plug in the charger, the breaker in the EVSE activates then the breaker in the car activates then I see the current on the EVSE readout ramping to about 20A then there is a noise from the car (sounds like a breaker opening) and it goes to 0A quickly. Then it will repeat a few times (I think about 5) and then the car gives up and shows the external charger error warning
There’s another large thread here about the onboard charger failing.....though in that case the car typically won’t charge with level 1 chargers either.

I will soon find out about this as our 2016 last night decided we couldn’t charge it any more (we’ve had it since September 2016). We have a level 2 EVSE from Clipper Creek that we’ve used since the second month of having it. It starts to charge then in a couple of minutes stops with one flash of all three LEDs. It won’t charge with the level 1 that came with the car either.

So tomorrow I call the dealer and then hopefully head down there to see what’s up. How they handle this will have a great bearing on whether we follow though on the plan to swap this car out for a 2020 Soul EV when the lease is up in September.