DC Charging not Working

Kia Soul EV Forum

Help Support Kia Soul EV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


New member
Jul 7, 2020
I recently purchased my used 2016 Kia soul EV and since I bought it I have only been able to charge using J1722 charge stations. I would really like to use CHAdeMO for quick charging, but whenever I try, all three blue lights flash for a second, then it immediately clicks off and says "charging session ended". I know it's not the station, because I have seen other people charge successfully.

Is there something simple that I'm missing/any advice on how to fix this?

Thanks in advance!
Personal opinion, but this issue isn't a mistake on your behalf but rather a genuine issue with the DC charger functionality in your car. This isn't something you've been doing wrong or can do something to fix. You need to take it into the dealership, hopefully you're still in warranty.

All the best!
Given the lack of info about this failed charging session I think we should try some more simple guesses before suggesting that the car needs to go to a dealer. Otherwise why post here, just take it to the nearest dealer and get it fixed.

1. If the car is already fully charged. The original 2015 Soul EV will stop fast charging at 83%.

2. If the car or the charger is overheated it may stop.

On my car this is the error I always see when fast charging fails.

Although other cars are able to be charged from that charger, are any of them Soul EVs? I know when the Soul EV first came out there were some DC chargers that it didn't work with. DC charging requires the charger to talk directly to the BMS, and some chargers had bugs in them that needed updates to work with the Soul EV.

If there are other Soul EVs that are successfully charging and your battery charge is low enough to DC charge but it is still failing then see if others have any advice on it - there's one charger near me that is notoriously bad and requires you to do the exact sequence of buttons on the charger, plugging the car in and timed charging button on the car pushed in before it will successfully charge. Try other chargers, check in plugshare if they are good ones.

If things are still not working then taking it to the dealer may be your only option. It could be something like the battery fan not working (people have had loose connections in the trunk) or it could be one of the connections in the charging wiring under the hood.
Newb here, so don’t trash too hard but...

Today I went to DCFC, and naturally I parked on the wrong side of the tower, opposite the Chademo plug. There was plenty of slack, so I lugged the cable over and plugged in, but after hitting ‘Start’ on the tower, it failed twice, “Transaction voided, disconnect the plug and try again...” Mind you, the cable wasn’t exactly taut, but definitely no slack. On the third attempt, I pulled a bit more on the restraint from the tower so the cable would be more relaxed, and it fired up without a hitch.

I’m not necessarily suggesting this is as a solution to OP’s issue, but It is something I’ll make sure to do from now on. As someone that knows virtually nothing about the inner-workings of these machines, I theorize that the little extra tension in the cable was keeping one of the com pins from making good contact...?

Anecdotal I know, but just my own experience.
Same thing is happening to me right now with my used Kia 2016 EV Soul. CHADEMO won’t work. I’m having to use the slow chargers and I’m only getting 41 miles per charge. I’m so very disappointed. I called Kia corporate and they gave me a case number. Been waiting for weeks to get into a dealer. I wonder if I will ever see 90 mile range as promised once fixed. Anyone have good results after repair?
Bad range means that you need a new battery. Everyone that I've seen who got a new battery got all the range back. It may take a couple of visits to the dealer. They update and reset the Battery Management System on the first visit, and the reset makes it display full range. Over the next little while the BMS relearns how bad the battery actually is and then you take it back to the dealer and they get a replacement battery from Kia.

The bad battery may also be preventing the DC fast charging as the bad cells may not accept the high speed charge.
Hetownsakia - I agree with notfred. The probable reason you can't fast charge is because your battery is really bad. I have had this issue on a Hyundai BlueON EV. Very easy to check. Just find a steep mountain road. A very degraded battery will not be able to accelerate up nor regen down.
The advice is simple, start the process of getting a replacement battery under warranty. Just look around this forum for numerous threads detailing how to do this.
2 Things have happened for my 02/16 built 2016 Soul EV +

DC charging stopped working in March 2020 with EVGo and private Dealer ChaDemo without throwing up any error or faults. Took to dealer after COVID restrictions loosened. Dealer saw no codes in memory. They said 2 software updates were needed. They updated and we went to DCFC Chademo station, EVgo, and voila, she charged.
Forward to last week Wednesday 9/16/2020, EVgo DC Chademo, arrived with 20% SOC, chademo peaked at 37kWh to 85%. Unplugged and started car. Immediately, in driver facing screen, orange EV! triangle appeared. Drove on a slow speed and Orange Turtle Reduce Power Mode appeared. We were but a few miles from our destination. I had seen this in 2017 once or twice and disappeared for near 2 years, so we slowly pushed on at 40mph max.
Coming out form Appt, started car, zero warnings or codes. Drove home, car performed normal.
This Monday 9/21/2020 drove to same place, arrived at 20% SOC 17 miles left, DC charger Chademo connected. Ramped up to 40kWh and then shut off throwing up 2 warnings in driver and center stack display External Charger Fault in black and white triangle in center stack and square plug warning in driver stack. Car would not charge.
Limped to 240v Charge Point outlet and sat for 2 1/2 hours to get mileage I needed to get home. No warnings on the dash or center stack. No orange Triangle, no power reduction etc.

Suspect DC Charger is shot. My car was built 02/16 out side of bulletin issues on 2016 builds by 2 months. Working through dealer now to have it looked at.
There's a similar thread in the UK. Doesn't mean the answer is the same though.
very slow CHAdeMO charge

Today we went back to one of the GeniePoint ones we'd had trouble at, found it still gave a very slow charge (averaged about 8kWh today). I phoned Evolt on 02084212411 while we were connected to the machine and they took diagnostics. The employee I spoke to was interesting and believes that the issue between the Kia Soul EV and their CHAdeMO chargers is limited to the "pre-production" Soul EVs. Mine was first registered in October 2014, so it's one of the earliest I believe.

He also said that Kia haven't come back to them about this issue when Evolt have tried to resolve it with them. (?)

I've started by contacting my local Kia dealer and asking if my firmware version is up to date. I'll see if an update will help, if available. Evolt reckoned that it was my car throttling the charge speed rather than their machine. We shall see.

We eventually booked the car into our local Kia dealership (Hawkins) who worked some sort of magic (under warranty) on my car. It now charges properly regardless of which chademo charger we're using. Yay.