Speedo and Battery Range Gauge in Imperial vs. Metric.

Kia Soul EV Forum

Help Support Kia Soul EV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Jun 7, 2019
Strange thing happened with our 2020 Soul EV last night; I went for a short drive and noticed while backing out of my carport that the estimated range seemed low. As I drove down my driveway, the indicated speed was in Miles Per Hour instead of Kilometers Per Hour! No one changed any settings (Only my wife and drive the car.), and the car wasn't plugged in. We did have a severe electrical storm take place but I doubt that could have caused the change. I went into the manual to change the settings back to metric, but the two Settings headings under "Other", "Speedometer Unit" and "Consumption Unit" as per page 5-55 in the Owners Manual are not there! So, I'm stuck. Can't figure out how to change the settings back to metric, and am driving around with the two gauges indicating in Imperial. Short of calling the dealer, does anyone have suggestions? I also tried voice command changing the settings, to no avail. I'm curious, the manual states that under "Settings", "Other" you can change the units from metric to imperial and back. Can any of you check to see if you have this option available?
Did you go to User Settings/Settings/Service Interval/ on the steering wheel?

I found a post where someone who travelled back and forth to the US wanted to change it and that was how he did it. I find the manual less than friendly due to all the legal bits and find stumbling around keys and menus really helps.
Ooops - Just checked and clearly some options do not appear on all models. The speedometer settings shown in the manual do not appear on my 2020 and the steering wheel menu does not include anything that helps either. May have to call dealer - at least - hopefully they have a backdoor way of correcting things.

Sorry I couldn't help. It may help others if you let us know how it was resolved.
gday: Thanks for that, yes, once it get it straightened out, I'll let everyone know how it was "fixed". I'm more concerned with how it changed to Imperial in the first place on it's own. Monday is a holiday, so I'll call Kia Customer Support on Tuesday.
Funny but something odd like that happened to me when I was returning a leased Toyota RAV4, my last ICE car - the last thing I did was remove my phone and contacts etc. When they looked over the car, as they always do they asked if I knew it was reading in mph. I was shocked and said no - if it was true I was WAY over the limit for returning it - then I remembered that after I removed my phone I went through the menu items quickly and saw, Reset to Defaults - I figured that was a quick way to get things back to normal. It must have been that that changed to imperial.

I am not suggesting you hit some reset but maybe a hiccup somewhere did a similar thing. I searched the web and found a few complaints that you can't make the change in a Kia but I feel it would be silly of them to write two entirely different pieces of software when it requires only a unit change. Maybe it can be done via the OBD port? Look forward to hearing what happens.
I think I may have got it.

Go into Maps then Navigation settings. Km or Miles appears in top right. I just tried changing mine to Miles and it changed the readout on the steering column screen. Hope that is the answer!
Thank you, that did indeed "fix" the problem! You saved me the ordeal of calling Customer Service and/or taking the car in to a dealership!
Great! I was lucky.

I vaguely remembered reading somewhere that the Navigation unit could be changed but I did not relate it to the steering wheel screen. So for fun I tried it and by accident noted out the corner of me eye a change. So I flipped back and forth and bingo! There are few things more satisfying than working out how the mind of a software programmer works. Of course it does not explain why it happened but software often does weird things.

Glad I could help. I could easily imagine how frustrating it was.